-
hernan604
-
geometry
hernan604: Sad at the state of PowerPC support in FreeBSD?
-
geometry
I would love to upgrade this machine to 128GB or better yet 256GB of memory; VMs tend to me limited by your system's memory.
-
karolyi
I have 43 jails running currently on 64GB ram
-
karolyi
hernan604: just out of curiosity, you've mentioned that you thought the hang is io-bound. did you try running "iostat -x -z 1" and see if around the hangs there are excessive reads/writes?
-
hernan604
-
hernan604
karolyi: do you use screen or tmux ?
-
hernan604
maybe you could try yourself ?
-
hernan604
start or stop a bastille jail and press ctrl+a to switch to another window (then it hangs for some seconds)
-
karolyi
hernan604: I don't use bastille but what you've pasted is nothing, no IO load at all
-
karolyi
must be something else then
-
hernan604
karolyi: right
-
runxiyu_
phabricator 429'ing me :(
-
runxiyu_
i'll ....
-
runxiyu_
just send a patch I guess?
-
karolyi
mason: you've mentioned you're going the "other way" with VNET jails, as in going back to non-VNET ones like I have. just out of curiosity, what's the complexity you don't like with the VNET jails? I'm thinking they must be not hard to set up, although I don't have a single one. I also thought FreeBSD is deprecating non-VNET jails so I'd have to switch over, over time
-
mzar
no-VNET jails work just fine
-
mzar
there is less overhead
-
mzar
less overhead => better network performance, more PPS
-
mzar
karolyi: what are you using 43 jails for?
-
karolyi
mzar: lots of small websites, services: prosody, matrix, yourls, unbound, named(bind), coturn, jitsi, go-away/sarracenia, fail2ban, nginx, teamspeak, a separate mailserver jail with dovecot/postfix/SA/etc, roundcube, buildbot... the list goes on
-
karolyi
lots of jails with php-fpm and uwsgi
-
mzar
very nice
-
mzar
is the bug report about PF not being supported from within the jail yours ?
-
karolyi
yep
-
mzar
OK, so fail2ban has problems now ?
-
karolyi
if it runs within a non-vnet jail managing pf, then yes. it's what I've hit, but already got it working with a little script- and prompt-fu in python
-
mzar
perhaps it should be allowed, for all firewalls, like routing updates
-
karolyi
I mean there's an 'allow.routing' for a similar purpose
-
karolyi
so one could argue for an 'allow.pf'
-
karolyi
-
mzar
karolyi: good point, let's raise this on the net@ mailing list
-
karolyi
it was already in the opening post if one reads carefully :)
-
karolyi
mzar: I'm just realizing you're Marek
-
karolyi
o/
-
mzar
I am also 100% addicted to non-VNET jails, and have only a few VNET-enabled ones - sometimes VNET demand is indispensable
-
mzar
yes, you can chcke it with /whois
-
karolyi
I read somewhere around when VNET was introduced that non-VNET will be phased out over time, which kinda made me anxious, but good to know that so many people are still relying on it that probably it's not gonna happen
-
mzar
FWIW, sysutils/ezjail got small update recently, so people will no longer claim that's not maintained
-
karolyi
I use my own ansible playbooks for building my jails
-
karolyi
comes super handy when making updates
-
mzar
neat
-
mzar
karolyi: AFAIK there are no plans do deprecate non-VNET jails
-
karolyi
-
karolyi
forgejo is also one of my 43 jails :)
-
» mzar bookmarks it
-
karolyi
doesn't handle vnet though so the only thing it can create is non-vnet which is what I'm using
-
mzar
what doesn't handle vnet ?
-
karolyi
the playbook. it only creates non-vnet jails
-
mzar
you can extend it
-
karolyi
I was thinking on it, yes
-
mzar
I am using ezjail for decates, and it supports vnet jails, though it's not docummented
-
mzar
s/decates/decades
-
karolyi
I also took a quick peek into that bastille thing yesterday, crazy someone did it in shellscript entirely
-
mzar
I have to go, have a nice jailing ! BBL
-
karolyi
mzar: my playbook relies on a template jail that gets cloned and then I did quita a bit of wizardry in ansible (at least it counted as such back when I've had to "exploit" things in it) to achieve deploying the jails properly
-
karolyi
the vars['somevar'] wasn't really public at first
-
karolyi
also the package revalidator evolved quite a bit and still has to with introducing the new package sources
-
karolyi
but that's only necessary if you use a local pkgmirror (nginx acting as a cache)
-
karolyi
oh, bbye
-
st_iron
that's great stuff, Laszlo
-
st_iron
nice work
-
st_iron
43 jails, wow
-
karolyi
st_iron: I didn't tell it to flex but thx anyways :)
-
st_iron
karolyi: yeah, it's fine, i just dropped my jaw with my 8 production jails :D
-
st_iron
well, not counting my bhyve vms
-
spork_css
I have already bought some cheap (scary) replacement SSDs so I'll have a combo of 2 off-brand SSDs and one Samsung 870, but I'm wondering if anyone more familiar with LSI controllers has any thoughts on these messages that started popping up the other day...
-
spork_css
-
spork_css
What's odd is prior to this there was nothing of note logged in the past week. I saw one SSD was showing high wearout, so I replaced it. That drive, brand new Samsung 870 ($200 for 512GB!) is da4 which is the first error logged. Then it seems like all hell breaks loose and all the drives go crazy.
-
spork_css
This is an OLD Dell R720 with a Dell-branded LSI controller flashed to IT firmware.
-
spork_css
SMART info pulled from scrollback - da0 is just gone, da1 and da2 clearly have issues, da4 is new and looks fine, which makes me wonder why it's showing up with issues right at boot...
paste.debian.net/hidden/0aa32aa7
-
spork_css
I've had weird stuff long ago with LSI controllers and SATA drives so now I always get a little suspicious about whether I'm seeing a true drive issue or a controller issue.
-
spork_css
and googling some of the controller messages brings up ancient bugs in bugzilla, some starting way back in the 11.x days and still getting new comments in 2025.
-
b_h
hey, if I have a freebsd 15.1 install where I selected pkgbase during the install, is it expected that FreeBSD-base is enabled=no in /etc/pkg/FreeBSD.conf?
-
lts
It's expected and wrong and should be fixed
-
b_h
anything else I should configure before updating to make sure my local config file modifications don't get clobbered? also, do I need to enable anything further to get updates for base and kernel and etc.?
-
b_h
the current update list looks pretty comprehensive but i've only recently converted from truenas to freebsd so still have a lot to learn
-
karolyi
I should do that too with my truenas... it's abandonware
-
b_h
it's worth it. was getting pretty leery of the lack of updates for 13.x and am pretty happy with the current setup
-
mason
karolyi: I'm fine with VNET jails but they're unnecessary complexity internally. More moving parts. And if that's not needed, why have it? Here is my guide for using VNET with jails. Compare a non-VNET equivalent and it's dramatically less.
wiki.freebsd.org/MasonLoringBliss/JailsEpair
-
mason
So, if I need a jail to be a DHCP client, I'll use VNET. Otherwise, I'm leaning hard towards simplicity.
-
karolyi
mason: hear hear, I'd also like to keep my non-vnet jails :)
-
spork_css
187 Uncorrectable_Error_Cnt -O--CK 096 096 000 - 39748
-
spork_css
should an ssd with numbers like this not be marked as "bad" by SMART?
-
spork_css
I also kind of feel like this should qualify as "bad"?
-
spork_css
# 1 Extended offline Completed: read failure 90% 33542 1548176
-
spork_css
I hate SMART stuff, totally inscrutable no matter how much I poke at it.
-
spork_css
¯\_💩_/¯ SMART overall-health self-assessment test result: PASSED
-
spork_css
This kind of wording also makes me bonkers: "When the command that caused the error occurred, the device was active or idle."
-
spork_css
Makes me feel like there's a third state besides active or idle.
-
rwp
SMART is really terrible. It never predicts a failure for me. But I do use it to confirm problems when I am seeing failures.
-
rwp
Almost everything about it is vendor defined. And no vendor wants to have their devices fail their own definition. So they mostly never say the device is failed. Even if it is failing a lot of things.
-
rwp
Meanwhile... To avoid the problem being controller or cables or other things, I always test the device in another completely independent system.
-
rwp
I have a "bench" system, a zimaboard system, with two SATA cables right there easy to plug in a SATA device. (Not for SAS, obviously.) And then I will run tests on it there. If it fails both places then it is the device. If it passes there then maybe I have a bad cable or power cord instead.
-
spork_css
-
spork_css
Is there a legit reason ftp-archive.freebsd.org is throttled to about 1MB/s?
-
spork_css
It's so painful, and it looks like they really push unsupported releases off the main server quickly (trying to get a 13.x image so I can fix my bootblocks so I can update to something supported).
-
spork_css
Oh, I see it's also 96.47.72.116/ftp0 is slow, but going in parallel to both it's 1MB/s each.
-
spork_css
Weird TE, you'd think they'd want people in and out of there as quickly as possible.
-
rwp
spork_css, Yup! Though I think my area might have a little less dust on it. :-)
-
rwp
I doubt ftp is being bandwidth limited. More likely it is getting pummeled by botnet scrapers and you are just a single thread competing with hundreds of other threads and so only getting the slip of what is left.
-
spork_css
I'll eat my shoe if it's not a per-connection limit. you can stack up 10 1MB/s downloads...
-
spork_css
I think the main ftp site has the geo-guessing DNS on it, and they probably drive traffic to other sites, but ftp-archive isn't officially mirrored anywhere so it suffers the same fate as the main site.