-
jnewt
I'm finally starting my upgrade from 13.2 to 14.0 on a production machine. next step is the 1st reboot. some reading has led me to think i may run into some issues since my root fs is on a mirrored zfs setup, but I'm not sure what (if anything, i need to do in order to ensure this reboot (which is remote btw) will go smoothly. any recs?
-
jnewt
I do plan on doing the minor upgrades as well, but only found successful instances of 13.2 to 14.0 as opposed to a bigger jump to 14.1 or 2 or whatever production is at this point
-
rwp
jnewt, I upgraded my desktop with mirrored zfs from 13.2 to 14.1 and had no trouble.
-
jnewt
good to know.
-
rwp
Personally I have always avoided the .0 releases because that's when they first met the community at large. A lot of us wait for the .1 to appear and then go for it.
-
rwp
Reminder that Boot Environments are created automatically on zfs systems on upgrade. ("bectl list") If you have a problem for any reason you can always boot, select the previous 13 boot environment, and be immediately back to your previously working system.
-
rwp
Reminder that after upgrading to 14 and rebooting to reinstall all of the binary pkgs "pkg upgrade -f".
-
rwp
The process is described in the Handbook but basically freebsd-update -r 14.1-RELEASE upgrade, freebsd-update install, then reboot then finish with freebsd-update install. Then pkg bootstrap -f to install fresh binary packages compiled for the installed and running release.
-
rwp
Then pkg autoremove to clean up older no longer needed lint things.
-
rwp
Since I am running many daemons from ports (postfix) I finish with a final reboot after the pkg upgrade -f so that I ensure that everything running is after the install. So that is two reboots in total.
-
jnewt
well, apparently my 120gb mirrored setup is no longer big enough, i can't complete the install due to disk space
-
rwp
The steady state of disks is full.
-
rwp
My root file system holding the OS is consuming 61GB on my 14 system.
-
jnewt
yup, they're full. and steady state. what can I dump to get through this? pkg autoremove safe mid upgrade? crash and logs. hope I don't need them.
-
jnewt
rwp, it's probably my 13 + 14 system that is the issue mid upgrade, probably a bunch of temp files
-
rwp
If you don't want/need older pkg files then "pkg clean" will clean out /var/cache/pkg. How much space is there? "du -sh /var/cache/pkg/"
-
rwp
Those are probably reasonable for most people to discard. Some people have many systems across versions and keep that shared as a cache for the collection.
-
rwp
Is /var/log particularly full? du -sh /var/log/
-
jnewt
7.5M
-
jnewt
what about these zroot/ROOT/13.2-RELEASE-p[4,4,5,11,12] directories / fs that it appears to have created that are huge.
-
rwp
Ah those are boot environments. Yes. Those older ones can be pruned off. bectl list
-
jnewt
probably need to keep the 14.0 one since that's the target. I have 5 13.2 ones. one of which is 82G, but it's not the newest one
-
jnewt
what's the best way to clean these out safely without torching something I may need?
-
rwp
bectl destroy bename for the older ones that you don't need to return too.
-
jnewt
why is one 80x the size of the others? that seems odd
-
rwp
Since zfs is all pointers and reference counting it is sometimes not obvious where disk space is being held and if there are multiple snapshots then the space is then just attributed to the next pointer up the line.
-
rwp
I would look at: zfs list -o space
-
jnewt
that looks different.
-
rwp
The 80x one (boot environment) means that space is uniquely there, as if it were running as a regular system for a while. Did you boot that one and run it for a while?
-
rwp
Boot environments are file system clones. Which is to say file system branches. They start as a fork from a snapshot and then as blocks are written then they grow in size to absorb the newly written data blocks to it.
-
jnewt
not sure I'm really going to gain enough then. default is 105G.
-
rwp
That's about where my desktop is sitting too.
-
jnewt
this is a server, no de, seems like it should be smaller
-
jnewt
zfs lists the space as 106G, not sure I have anywhere to go here
-
rwp
Here is a smaller system of mine, 120GB SSD, no X headless, with some jails and random stuff:
termbin.com/ie08
-
jnewt
that site (termbin is blocked for me
-
rwp
Do you have space in snapshots? Try: zfs list -t snapshot -s used
-
rwp
I would use bsd.to pastebin (see topic) but it has been offline for months now.
-
rwp
I must relocate. Good hunting on the disk space!
-
jnewt
thx
-
crb
I have a epyc 7313 server that hangs during boot right after/durring EFI framebuffer message, any ideas?
-
jnewt
so i cleaned up those old 13.2 envs and tried to re-run the freebsd-update install and now i'm in a src component not istalled problem. i did not touch default or the new 14.0 one. where did i go wrong?
-
jnewt
and trying to fetch again ends me with an Invalid key fingerprint error
-
jnewt
what's my risk level of reboot vs trying to utilize a remaining 13.2 boot environment listed in bectl?
-
jnewt
whelp, I lost it. crap rebooted and now i can't ssh into it anymore.
-
jnewt
I hate upgrades
-
rwp
This was on a remote system? But it only had 120GB total mirrored? Any remote console access to it?
-
jnewt
I'm on-site now. It was remote, but not too remote
-
jnewt
used bectl to load back into an old 13.2 environment. now it shows a default and two 14.0's that are not marked NR since I'm in the 13.2.
-
tuaris
It's always so hard to find the docs on how to remove (for example) a '.' period, from the value of a shell variable without having to use sed/awk/tr. Using parameter expansions. Am I remembering incorrectly, or is it not possible with regular `sh`
-
rwp
jnewt, If you are booting from the console then at the "beastie" boot prompt there is a menu item to select any previous boot environment.
-
rwp
Of course N is active Now and R is on the next Reboot.
-
rwp
tuaris, To find this in the "man sh" page search for %% and it will take you right to the area you are looking for.
-
rwp
So for example if foo=bar.txt and one wants to remove .txt then echo ${foo%%.txt} will do it.
-
tuaris
You can't do something like turning 8.3 into 83 from what I've read so far?
-
rwp
That's basically the equiv to "basename $foo .txt" but all internal to the shell.
-
rwp
Hmm... 8.3 to 83... Not without splitting into two variables and then joining the variables again.
-
rwp
It only has one dot in it? Not more? Try this: echo ${foo%%.*}${foo##*.}
-
rwp
That won't work for 3 or more dots (so I worry about it) but will work for two.
-
rwp
I hesitate to ask because I am sure it is version letter conversions and I doubt I would approve so I will just stick my fingers in my ears and sing la la la la la.
-
tuaris
it's always going to be one dot since that's the way the PHP ports are named
-
tuaris
8.2 -> php82
-
tuaris
8.3 -> php83
-
sidh
Greetings
-
plasma
good morning
-
sidh
Is there a tool that provide a dependancy tree of installed pkg ?
-
plasma
depends on which distro and package manager i would assume
-
sidh
either in GUI or CLI ( tree cmd like ) mode
-
sidh
on freebsd 12.3 +
-
plasma
ah sorry, wrong window i thought its #linux, sorry ;D
-
sidh
plasma: I 'd bet you have a kde tab too on your irc client ;)
-
plasma
sidh: nope
-
plasma
im strict enlightenment user since ages
-
plasma
got this nickname in the 90s, i think that was before KDE Plasma
-
plasma
but the highlights in the channels, and my interactions are sometimes funny ;D
-
sidh
congrats, I tried several times e17, but did'nt manage to get used to
-
plasma
actually im using e17 fork moksha right now, from jeff hoogland from bodhi linux
-
sidh
stick with i3 for ages
-
plasma
i got used to the engage dock as module, and it wasnt continued since e18
-
plasma
raster says itask/ibar or how its called provides the same functionality and similar feeling, but its not the same
-
sidh
bodhi linux , I tried it , woaow , say 12, maybe 15 years ago , glad to see it is still active
-
plasma
for some i might appear like an apple fanboy because of the dock, but im totally not
-
sidh
iirc e17 was used (forked) for nokia n900 phones
-
sidh
does tizen has any relation with e17 ?
-
sidh
and tizen after with samsung iirc
-
plasma
there was a general project for e on mobiles, dont know if its still continued or how the development status is
-
plasma
dont know about tizen
-
sidh
enlightenment.org/news/2024-08-06-evisum-0.6.1 "Much of this was written from a psychiatric ward bed. "
-
plasma
btw if somebody is using arch here as desktop, i repaired moksha and moksha-modules, or better said the dependencies on AUR, if somebody wants to try this e17 fork
-
plasma
sorry for being kinda offtopic channel wise ;)
-
erk
Does anyone here have any insight into why this port does not exist on pkg? I just tried to build it locally and it worked fine:
bugs.freebsd.org/bugzilla/show_bug.cgi?id=281338
-
vkarlsen
-
erk
Ahh guess it was fixed in this commit then:
freebsd/freebsd-ports e5be14a
-
erk
So it is just waiting in the queue to be rebuilt.
-
dch
aaahm is there any whatsapp solution for freebsd desktop? I never used it in the past, but $KID school now requires it.
-
dch
I don't want to keep it on my phone but I'm ok with setting it up once, and then deleting the app entirely.
-
kwiat
dch: maybe
web.whatsapp.com will work for you?
-
kwiat
it worked for me in Firefox
-
dch
kwiat: lol thats ideal... I can do it in a container. now to see if I can sign up without giving up all my info
-
dch
didnt expect there to be a simple www page
-
kwiat
there's no signup :-)
-
dch
kwiat: right, but i already have to sign up on a phone first
-
kwiat
ah, ok!
-
jnewt
i'm having issues updating to v14.x from 13.2. I'm following the std installation guide. the issues occur after the 1st reboot. last time it was some key problem getting the updates. This time i'm getting rmdir: ///var/db/portsnap: Directory not empty done.
-
jnewt
should i just attempt to wipe out the contents of that directory so it can continue
-
jnewt
or maybe i should freebsd-update fetch again to get any sort of updates that would fix this issue?
-
hadret
jnewt: portsnap has been removed from base in 14. you either need to ditch it completely or install it from ports. seems like installer wanted to clean in up but couldn't as there was some data inside
-
nicholau104
Howdy, folks!
-
debdrup
-
daemon
jnewt, mv /var/db/portsnap /var/db/portsnap.backup
-
CrtxReavr
sudo ln -s /dev/full /var/db/portsnap
-
rwp
I don't think that symlink will prevent errors since /var/db/portsnap is a directory not a regular file.
-
jaredj
that's what i was thinking too.
-
jaredj
maybe you could mount a tmpfs with a really small size? it would be a filesystem, but be full
-
rwp
I don't know why removing it or moving it out of the way didn't work. A fresh install of 14 does not include it.
-
jaredj
i have not scrolled up at all so i don't know any of the context
-
» jaredj hands everyone a grain of sald
-
» jaredj ... also hands everyone a grain of salt
-
CrtxReavr
I dropped mine. Can I get another?
-
jaredj
i suppose. you are worth your salt. :)
-
nicholau104
...As well as some "sald".
-
jaredj
yep, be careful with that stuff
-
nicholau104
Outside of that, i'm just looking over some IRC chats while i'm doing some programming for my project.
-
nicholau104
Basically, i have irssi running on the right pane in tmux, and 2 terminals on the other side.
-
nicholau104
And i'm doing this via SSH on a Tiny11 machine, with the SSH server running on my main FreeBSD PC.
-
nicholau104
Other than that, that's all i'm here for. Silent, but slightly wisecracking.
-
nicholau104
Hey, it's kinda good to IRC and Vim all at the same time.
-
nicholaus04
There we go, now i have the right nick.
-
jaredj
heh. i have my todo list on the left screen and my irc on the right screen in X, running in two emacsclients against the same instance of emacs, with my NFS home backed by my main FreeBSD PC :)
-
nicholaus04
jaredj: Nice.
-
jaredj
certain parallels obtain, despite several contrasts
-
nicholaus04
As for what i'm working on, it's a libc reimplementation, made for the engine that my project is running on.
-
nicholaus04
ATM, i only have every function in ctype.h, and rand/srand made.
-
nicholaus04
Though, rand/srand is based on it's example implementation from POSIX, but this makes it easy to work with on multiple platforms.
-
dwho
Hello everybody, I try to make cjdns but the port is broken , I wish to install with an older version but I don't know to do it.
-
dwho
I wish to install an older version of rust
-
rwp
A reading of those things sent shivers down my spine. Installing an older port. Installing an older version of Rust. I am chilled to the bone thinking about how much work that would entail.
-
dwho
I think to use poudriere but I never use it
-
dwho
Or I repair the broken port but I'm not programming
-
dwho
I can compile cjdns with github clone under debian but I don't make this under freebsd
-
f451
hi, does bhyve still need grub2-bhyve for netbsd10 guest?
-
mzar
f451: most likely yes, can't NetBSD boot from EFI ?
-
f451
mzar: i dunno, there's little guidance
-
f451
lots of things say "use sysutils/vm-bhyve" but id prefer not, because on the system there are already vms
-
f451
and there's no clear way of getting that port, once installed, to run an image that has already run with either vmrun.sh or grub2-bhyve